Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Digital Measures login issue
Incident Report for MSU Denver ITS
Resolved
The issue with Digital Measures logins have been resolved.
Posted 2 months ago. Apr 13, 2019 - 06:53 MDT
Monitoring
Digital Measures is currently experiencing an intermittent issue with logging users into their system. If you are not able to login to Digital Measures, please close your browser and try again. We will provide updates once we receive back information from Digital Measures.
Posted 2 months ago. Apr 12, 2019 - 12:15 MDT
This incident affected: Digital Measures.