Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Lyris list server is down
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Oct 12, 2020 - 09:04 MDT
Update
We are continuing to investigate this issue.
Posted Oct 12, 2020 - 09:00 MDT
Update
Lyris is up
Posted Oct 12, 2020 - 09:00 MDT
Investigating
We are currently investigating this issue.
Posted Oct 12, 2020 - 08:53 MDT
This incident affected: Lyris.