Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Network Service Degradation
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Dec 04, 2024 - 09:04 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 03, 2024 - 14:57 MST
Update
Technicians are aware of the issue and are working to resolve it as quickly as possible.
Posted Dec 03, 2024 - 10:52 MST
Investigating
We have received multiple reports of network service degradation on campus. There are ongoing issues in admin due to the network mod upgrade that is affecting printers and network jacks throughout the building. Technicians are aware of the issue and are working to resolve it as quickly as possible.
Posted Dec 03, 2024 - 08:41 MST
This incident affected: Campus Network and Campus Wireless Network.