Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

SSC Navigate
Incident Report for MSU Denver ITS
Resolved
The issue with Navigate Student was resolved overnight and student should now be able to login via the student hub at https://www.msudenver.edu/studenthub

If you experience any further issues, please contact the ITS Service Desk at 303-352-7548 (24/7) for assistance.
Posted Oct 27, 2021 - 08:17 MDT
Update
The vendor is working on a resolution to student access to Navigate (Advising) Student and should have a resolution by 8am on October 27th.
Posted Oct 26, 2021 - 16:08 MDT
Identified
The Vendor is currently working on the issue to resolve as quickly as possible. To temporary access Navigate (Advising) Student, please visit: https://msudenver.campus.eab.com/home/student

We anticipate a status update from the vendor soon.
Posted Oct 26, 2021 - 12:19 MDT
Investigating
At this time, MSU Denver is experiencing an unplanned service interruption impacting SSC Navigate. Technicians are aware of the issue and are working to resolve it as quickly as possible. We anticipate a status update on this issue in the next 60 minutes.
Posted Oct 26, 2021 - 10:44 MDT
This incident affected: SSC Navigate (Advising) Student.