Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Self-Service Password Reset Funtionality Degraded
Incident Report for MSU Denver ITS
Resolved
Self-Service Password Reset appears to be working normally at this time.
Posted 7 months ago. Oct 16, 2018 - 07:15 MDT
Investigating
We are currently investigating this issue.
Posted 7 months ago. Oct 15, 2018 - 13:32 MDT