Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Main webpage (www.msudenver.edu)
Incident Report for MSU Denver ITS
Resolved
Update has been completed
Posted 24 days ago. Aug 29, 2019 - 15:12 MDT
Identified
ITS will apply an emergency update at 1pm to the main website. User may see certificate errors between 1pm and 105pm.
Posted 24 days ago. Aug 29, 2019 - 11:49 MDT
This incident affected: Campus Web Hosting.