Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Office 365 MFA login not functioning
Incident Report for MSU Denver ITS
Resolved
MFA is back up and working. will be sending out an email and closing the global ticket.
Thank you,
Waleed E.
Posted Oct 18, 2019 - 10:23 MDT
Update
MFA is still not available. ITS is monitoring the office 365 website for any updates. If you are logging into office 365 on campus, it is available without MFA enabled. But if you are outside of the campus you will not be able to login to your office 365 account due to the MFA outage.
Posted Oct 18, 2019 - 09:48 MDT
Identified
At this time, MSU Denver is experiencing service interruption on Office 365 MFA ( multi factor authentication) login. Technicians are aware of the issue and monitoring Microsoft website. Microsoft MFA is down nationwide. We will keep the campus informed.
Posted Oct 18, 2019 - 08:29 MDT
This incident affected: Office 365/Email.