Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Exchange Hybrid (smtp server)
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 11, 2018 - 08:52 MDT
Investigating
At this time, MSU Denver is experiencing an unplanned service outage on the Exchange Hybrid SMTP Server. Technicians are aware of the issue and are working to resolve the issue as quickly as possible.
Posted 2 months ago. Jun 11, 2018 - 08:12 MDT
This incident affected: Office 365/Email.